Check out our Winter Sale *Discounts Apply At Check Out

Kränzle Pressure Washer Won't Turn On

Can't get your unit to start?

Your Kranzle pressure washer won't start and you've got no clue what's going on? Odds are the pressure switch piston is stuck. This actuates the pressure switch, making the motor “think” that the pump is in bypass.

Fortunately, it's really easy to diagnose whether or not that is the issue.


First, locate the black pressure switch housing (page 34 of the owner's manual, item #60). Remove the two screws (item #69). Take care not to drop the nuts (item #62) in the bottom of the housing, as they can sometimes fall out and disappear.

Second, wiggle the pressure switch housing and pop it off of the brass fitting on the side of the pump. Now you should be able to turn ON the power switch and the motor should run. If it does, the stainless steel pressure switch piston (item #57) should be sticking out approximately 1/8”-1/4” from the brass fitting. In proper operation, the piston should shift inward and be flush with the brass fitting when spraying the gunjet.  It’s only supposed to shift outward when the trigger is released and the pump is in bypass.

The piston can get stuck in position when plaque builds up on the piston or O-rings.  It can also happen if the gunjet or high-pressure connections leak persistently, causing the machine to short cycle on and off for a period of time. This can result in premature failure of the O-rings. Then again, sometimes the O-rings just warp and get stuck.

Occasionally, the problem will automatically fix itself when you remove the pressure the pressure switch housing. If not, try removing, cleaning, and lubing the stainless steel pressure switch piston.  Take care to make sure that the small O-rings and washers don’t swift askew in the bore of the pump when re-inserting the piston.

It that doesn't fix the problem, the last resort is to replace the entire pressure switch control piston. You can order the repair kit here.

If troubleshooting the pressure switch leads to a dead end, then the issue is likely an electrical one. Check for voltage up to and through the on/off switch & PSI micro switch (the micro switch very rarely fails).  Lastly, it could be a failed capacitor. You can also test that, if you have a suitable meter.